请选择 进入手机版 | 继续访问电脑版

『瀚思彼岸』» 智能家居技术论坛

 找回密码
 立即注册
查看: 522|回复: 16

[技术探讨] N1盒子安装hassio的一些问题

[复制链接]

14

主题

157

帖子

493

积分

中级会员

Rank: 3Rank: 3

积分
493
金钱
336
HASS币
0
发表于 2019-7-10 06:52:10 | 显示全部楼层 |阅读模式
把N1盒子刷入5.60版的armbian,并安装了hassio有几个问题我汇总下,各位路过的大神,看看你们有遇到过么?
1:想刷更高版本的armbian,比如5.90的,刷入后,不能联网,插网线都不能识别,修改那个 文件也无济于事,只有换回5.60才ok
2:安装hassio0.95.4后,不能自定义设备名称,比如灯泡,修改后20秒就恢复原来的状态了,在customize.yaml里面有刚刚编辑的信息!
3:www文件夹里面放的js文件,能浏览器访问到,实际配置的时候不能读取到,很蛋痛,换了两个N1都是一样的
小白坐等大佬指点,好人一生平安
回复

使用道具 举报

7

主题

1844

帖子

4811

积分

论坛元老

流水无味

Rank: 8Rank: 8

积分
4811
金钱
2967
HASS币
145

灌水之王

发表于 2019-7-10 07:40:31 | 显示全部楼层
可以试试直接编辑 customize.yaml 后重启 没见到过不能自定义名字这情况
www.里面的js是干嘛?  lovelace吗? 插件要加载而且注意有些老的插件可能不能用
回复

使用道具 举报

14

主题

157

帖子

493

积分

中级会员

Rank: 3Rank: 3

积分
493
金钱
336
HASS币
0
 楼主| 发表于 2019-7-10 09:42:59 | 显示全部楼层
xieahui 发表于 2019-7-10 07:40
可以试试直接编辑 customize.yaml 后重启 没见到过不能自定义名字这情况
www.里面的js是干嘛?  lovelace吗 ...

老插件不能用的话,我用树莓派安装的就一切正常,所有才来询问下下
回复

使用道具 举报

7

主题

1844

帖子

4811

积分

论坛元老

流水无味

Rank: 8Rank: 8

积分
4811
金钱
2967
HASS币
145

灌水之王

发表于 2019-7-10 10:38:59 | 显示全部楼层
具体情况要详尽描述, 你这样JS不能用啥都不说清楚发帖要不是我为了水贴根本没人理睬你
回复

使用道具 举报

4

主题

46

帖子

144

积分

注册会员

Rank: 2

积分
144
金钱
98
HASS币
0
发表于 2019-7-10 11:22:39 | 显示全部楼层
我在两个n1上都成功安装了5.90没有遇到问题,建议直接用https://yadi.sk/d/srrtn6kpnsKz2/Linux/ARMBIAN的作者原版镜像
回复

使用道具 举报

14

主题

157

帖子

493

积分

中级会员

Rank: 3Rank: 3

积分
493
金钱
336
HASS币
0
 楼主| 发表于 2019-7-10 11:24:47 | 显示全部楼层
yiti8 发表于 2019-7-10 11:22
我在两个n1上都成功安装了5.90没有遇到问题,建议直接用https://yadi.sk/d/srrtn6kpnsKz2/Linux/ARMBIAN的 ...

谢谢……我试试呢
回复

使用道具 举报

14

主题

157

帖子

493

积分

中级会员

Rank: 3Rank: 3

积分
493
金钱
336
HASS币
0
 楼主| 发表于 2019-7-10 11:29:40 | 显示全部楼层
yiti8 发表于 2019-7-10 11:22
我在两个n1上都成功安装了5.90没有遇到问题,建议直接用https://yadi.sk/d/srrtn6kpnsKz2/Linux/ARMBIAN的 ...

老哥,现在最新的是5.91,你安装的哪一个呢?Armbian_5.91_Aml-s905_Debian_buster_default_5.1.0_20190708还是Ubuntu那个呢?,写入U盘后,替换dtb和修改uEnv.ini对吧?
回复

使用道具 举报

4

主题

46

帖子

144

积分

注册会员

Rank: 2

积分
144
金钱
98
HASS币
0
发表于 2019-7-10 11:32:08 | 显示全部楼层
scboy 发表于 2019-7-10 11:29
老哥,现在最新的是5.91,你安装的哪一个呢?Armbian_5.91_Aml-s905_Debian_buster_default_5.1.0_201907 ...

我当时用的是5.90的debian无桌面版,内核选5.1.0,然后替换修改就好了。
回复

使用道具 举报

14

主题

157

帖子

493

积分

中级会员

Rank: 3Rank: 3

积分
493
金钱
336
HASS币
0
 楼主| 发表于 2019-7-10 11:39:18 | 显示全部楼层
yiti8 发表于 2019-7-10 11:32
我当时用的是5.90的debian无桌面版,内核选5.1.0,然后替换修改就好了。

再问下老哥,内核5.10怎么选?是去下载么?我刚下载了5.91debian无桌面版,写入替换后,不能启动,一直卡在logo处
回复

使用道具 举报

3

主题

157

帖子

394

积分

中级会员

Rank: 3Rank: 3

积分
394
金钱
237
HASS币
0
发表于 2019-7-10 12:06:24 | 显示全部楼层
最新的buster貌似有很多不支持吧,得用stretch版吧,我记得。。。
现在不是说最好用的是5.77的版本吗,替换dtb就很稳定很赞。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|Hassbian

GMT+8, 2019-10-19 20:07 , Processed in 0.094071 second(s), 21 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表