请选择 进入手机版 | 继续访问电脑版

『瀚思彼岸』» 智能家居技术论坛

 找回密码
 立即注册
查看: 220|回复: 12

[经验分享] 关于多模网关接入ha后的问题#更新找到故障原因

[复制链接]

16

主题

283

帖子

1088

积分

金牌会员

Rank: 6Rank: 6

积分
1088
金钱
805
HASS币
0
发表于 6 天前 来自手机 | 显示全部楼层 |阅读模式
本帖最后由 AnyLine 于 2020-11-28 15:18 编辑

参照论坛,终于成功将多模网关接入ha,多模的软件版本是最后一版1.4.6_0030,ha版本是最新版。
但是用着很不稳定,经常出现蓝牙温度计不更新,起初没注意,后来发现蓝牙温度计不更新时候zigbee子设备也是失控了,只有蓝牙mesh设备可控。也就是zigbee子设备和蓝牙非mesh子设备都已经失去通信,只有蓝牙mesh(比如mesh灯泡)可控,米家里面一直没问题都可以控制和查看,多模也没掉线。

求大神分析故障,问题出在哪里了
更新,找到了故障原因,ha版本的锅。
使用一键切换ha脚本降级到找到原因了,ha降级到0.117.2版本左右,恢复正常使用。感谢楼下大神提醒。

Homeassistant 版本切换脚本
wget https://code.aliyun.com/neroxps/ ... stant_ver_switch.sh
chmod u+x homeassistant_ver_switch.sh
./homeassistant_ver_switch.sh 0.117.2
回复

使用道具 举报

6

主题

296

帖子

963

积分

高级会员

Rank: 4

积分
963
金钱
667
HASS币
0
发表于 6 天前 | 显示全部楼层
我感觉是更新了程序的问题,以前我的没什么问题现在和你问题差不多,明明网关在线,设备结果是离线的,我用的是小米插座
回复

使用道具 举报

16

主题

283

帖子

1088

积分

金牌会员

Rank: 6Rank: 6

积分
1088
金钱
805
HASS币
0
 楼主| 发表于 6 天前 来自手机 | 显示全部楼层
peter5858 发表于 2020-11-22 11:28
我感觉是更新了程序的问题,以前我的没什么问题现在和你问题差不多,明明网关在线,设备结果是离线的,我用 ...

更新了ha后吗?我感觉好像也是,因为刚接入的前几天感觉还好,然后后来更新了一两次,开始频繁掉线了了
回复

使用道具 举报

16

主题

283

帖子

1088

积分

金牌会员

Rank: 6Rank: 6

积分
1088
金钱
805
HASS币
0
 楼主| 发表于 6 天前 来自手机 | 显示全部楼层
peter5858 发表于 2020-11-22 11:28
我感觉是更新了程序的问题,以前我的没什么问题现在和你问题差不多,明明网关在线,设备结果是离线的,我用 ...

我的是看不到子设备离线,传感器是数据不更新,插座是不可控了
回复

使用道具 举报

16

主题

283

帖子

1088

积分

金牌会员

Rank: 6Rank: 6

积分
1088
金钱
805
HASS币
0
 楼主| 发表于 6 天前 来自手机 | 显示全部楼层
现在多模还能正常接入的,你们ha是哪个版本啊?
回复

使用道具 举报

10

主题

91

帖子

831

积分

论坛分享达人

积分
831
金钱
735
HASS币
60
发表于 6 天前 | 显示全部楼层
本帖最后由 dscao 于 2020-11-22 13:58 编辑

我感觉更新最新版后这个多模网关下的子设备状态比之前更准确了。
之前每次重启ha后,蓝牙夜灯的无人移动时间会变成0,门磁的状态变为开启亮暗变为亮,导致自动化的条件错误。
现在新版的重启ha后,这些状态保持重启前的,只是变化时间变成了开机时间。这样自动化的就不会因为这些而错乱了,折腾或升级而需要重启,这样就不影响了。
蓝牙温度计2从接入一直感觉还算稳定。刚加了一无线开关和天然气报警器,看起来也一切正常。
不过也才运行1天,还要不折腾不重启的情况下多运行几天看看。
Home Assistant 0.118.2;几天前更新的的XiaomiGateway3,过一会儿再更新一下。
1.jpg


2.jpg

5.jpg

3.jpg



回复

使用道具 举报

16

主题

283

帖子

1088

积分

金牌会员

Rank: 6Rank: 6

积分
1088
金钱
805
HASS币
0
 楼主| 发表于 6 天前 来自手机 | 显示全部楼层
dscao 发表于 2020-11-22 13:55
我感觉更新最新版后这个多模网关下的子设备状态比之前更准确了。
之前每次重启ha后,蓝牙夜灯的无人移动时 ...

我也是这个版本的ha,多模网关插件也是前几天的。
我的是N1,现在重启ha后恢复连接,但是2小时候后又失联了。
回复

使用道具 举报

12

主题

144

帖子

759

积分

高级会员

Rank: 4

积分
759
金钱
615
HASS币
30
发表于 6 天前 来自手机 | 显示全部楼层
等更新或者装老版本的吧,有几个人在issue提到这个问题了
回复

使用道具 举报

16

主题

283

帖子

1088

积分

金牌会员

Rank: 6Rank: 6

积分
1088
金钱
805
HASS币
0
 楼主| 发表于 6 天前 来自手机 | 显示全部楼层
froggyfly 发表于 2020-11-22 17:49
等更新或者装老版本的吧,有几个人在issue提到这个问题了

哪个版本可以?具体记不住着了,大概是更新了三四次到0.118.2,问题更频繁了。
回复

使用道具 举报

12

主题

144

帖子

759

积分

高级会员

Rank: 4

积分
759
金钱
615
HASS币
30
发表于 5 天前 | 显示全部楼层
AnyLine 发表于 2020-11-22 22:27
哪个版本可以?具体记不住着了,大概是更新了三四次到0.118.2,问题更频繁了。 ...

我现在是0.117.2,gateway3版本应该是0.10.0还是多少,反正不是最新的,毫无问题,我运行的是zha模式,蓝牙和mesh也没毛病
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|Hassbian

GMT+8, 2020-11-28 21:34 , Processed in 0.094916 second(s), 34 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表