请选择 进入手机版 | 继续访问电脑版

『瀚思彼岸』» 智能家居技术论坛

 找回密码
 立即注册
查看: 135|回复: 6

[技术探讨] esphome ota失败 求教(已解决)

[复制链接]

3

主题

43

帖子

180

积分

注册会员

Rank: 2

积分
180
金钱
137
HASS币
0
发表于 2020-6-30 15:03:07 | 显示全部楼层 |阅读模式
本帖最后由 wardwangyz 于 2020-7-1 08:52 编辑

串口写入正常,但是ota总是失败 请问如何解决啊
========================= [SUCCESS] Took 21.52 seconds =========================
INFO Successfully compiled program.
INFO Resolving IP address of esp01.local
INFO  -> 192.168.0.58
INFO Uploading config/esp01/.pioenvs/esp01/firmware.bin (403056 bytes)
Uploading: [==                                                          ] 3% 
ERROR Error sending data: [Errno 104] Connection reset by peer

二楼正解
回复

使用道具 举报

5

主题

329

帖子

1129

积分

金牌会员

Rank: 6Rank: 6

积分
1129
金钱
800
HASS币
0
发表于 2020-6-30 22:56:00 | 显示全部楼层
ESP配置最开始的板子定义改成ESP01_m试试

esphome:
  name: AAAA
  platform: ESP8266
  board: esp01_1m

回复

使用道具 举报

150

主题

2332

帖子

5180

积分

超级版主

我就是六神

Rank: 8Rank: 8

积分
5180
金钱
2838
HASS币
298

活跃会员教程狂人灌水之王

QQ
发表于 2020-7-1 00:28:30 | 显示全部楼层
不贴代码怎么给你看~
回复

使用道具 举报

3

主题

43

帖子

180

积分

注册会员

Rank: 2

积分
180
金钱
137
HASS币
0
 楼主| 发表于 2020-7-1 08:40:28 | 显示全部楼层
bjy2005 发表于 2020-6-30 22:56
ESP配置最开始的板子定义改成ESP01_m试试

我是 esp826601s的板子 应该选哪一个啊
回复

使用道具 举报

3

主题

43

帖子

180

积分

注册会员

Rank: 2

积分
180
金钱
137
HASS币
0
 楼主| 发表于 2020-7-1 08:41:51 | 显示全部楼层
jyz_0501 发表于 2020-7-1 00:28
不贴代码怎么给你看~
esphome:
  name: hanglamp
  platform: ESP8266
  board: nodemcuv2

wifi:
  ssid: "212"
  password: "12345789"

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "Hanglamp Fallback Hotspot"
    password: "iUO4Gs6G7Rfw"

captive_portal:

# Enable logging
logger:

# Enable Home Assistant API
api:

ota:

binary_sensor:
  - platform: gpio
    pin:
      number: 2
      mode: INPUT_PULLUP
      inverted: true
    name: "Power Button"
    on_press:
      - switch.toggle: relay

  - platform: status
    name: "Status"

switch:
  - platform: gpio
    name: "realy"
    pin: 0
    id: relay
回复

使用道具 举报

3

主题

43

帖子

180

积分

注册会员

Rank: 2

积分
180
金钱
137
HASS币
0
 楼主| 发表于 2020-7-1 08:51:28 | 显示全部楼层
bjy2005 发表于 2020-6-30 22:56
ESP配置最开始的板子定义改成ESP01_m试试

感谢 正解
回复

使用道具 举报

5

主题

329

帖子

1129

积分

金牌会员

Rank: 6Rank: 6

积分
1129
金钱
800
HASS币
0
发表于 2020-7-1 17:11:38 | 显示全部楼层

客气~~~我也是小白, 走了很多弯路  最后才发现这个问题 呵呵   以后多交流
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|Hassbian

GMT+8, 2020-7-15 15:36 , Processed in 0.086171 second(s), 30 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表